Tag Archives: troubleshooting

Winload.exe is missing or corrupt

When you boot the computer and you may get the error ” Windows fails to start, try recent hardware or software might be the cause. C:windowswinload.exe is corrupt or missing. Error – 0xC000000F”.  You are getting this message due to the corrupted winload.exe files.

Resolution:

  1. Boot the computer with the help of Xp disk to the WINRE ( i.e Recovery Console or command prompt)
  2. Run the chkdsk /f
  3. Run bootcfg /rebuildbcd
  4. Run bootrec /fixmbr and then bootrec /fixboot
  5. Type Exit
  6. Restart the computer

You will be successfully booted to the Desktop and the Computer would be up and running fine.

Application failed to start – side-by-side configuration incorrect

IF you get this error message while opening a particular application or program in windows vitsa  “Application failed to start – side-by-side configuration incorrect” this error is saying that finding that special dll written for that application is not working somehow then just uninstall and reinstall that particular application.

Or if getting this error while you are trying to run most of applications including the Internet exlorer in that case

    You need to remove all the temporary files from

  1. TEMP Folder
  2. %temp% Folder
  3. Prefetch Folder
    Boot the computer in safemode, doctor then Run the command prompt as Administrator, pills start->programs->accessories->Command prompt->Right click on command prompt and select run as administrator .
    Type the command sfc /scannonw

This command repair the corrupted files of windows. This will take 10-15 minutes to complete the scan.

    Restart the computer
    Run the applications.

Note: If you get the message some files could not repair the you might have to perform the inplace upgrade of windows as some of the windows files got corrupt.

Com surrogate has stopped working

If you’ve been getting the error COM Surrogate has stopped working whenever you browse folders containing video or media files, This problem is caused because of codecs and other COM components installed by various softwares that aren’t fully Vista-compatible, like some versions of DivX or Nero.
Here’s the error message:

There are a number of possible solutions to this problem, and the right solution depends greatly on what software is actually causing the problem. Some of the most well-known problem causing softwares are DivX and Nero, but there are others that cause the problem as well.
Possible Solutions

  • If you are using DivX, you should be upgraded to the very latest version (6.5+)
  • If you are using Nero, you can try upgrading to the latest version (7.7.5.1+)
  • If you’ve upgraded Nero and Divx and still have the problem, you can try renaming the file C:\Program Files\Common Files\Ahead\DSFilter\NeVideo.ax to NeVideo.ax.bak.  You may also need to rename NeVideoHD.ax to NeVideoHD.bak. This will break Nero Showtime, however. (thanks to dugi in the comments for this one)
  • You can disable Thumbnail previews, which should make the problem go away, but isn’t the optimal solution
  • The older ffdshow codec pack has been known to cause some problems. The ffdshow tryouts codec pack seems to work better. Might want to try using this one:  http://ffdshow-tryout.sourceforge.net/
  • If you’d like to uninstall Nero entirely, there is a utility that they provide to help with complete uninstall that helps a lot in instances where you have a bad installation of an older version. http://www.nero.com/nero7/eng/FAQs_Nero7_NeroVision.html
  • Some users have recommended installing the Vista Codec Package in order to update all your codecs to the correct versions. I can’t confirm that this works because I have not tried it myself. As always, be careful when installing unknown components and create a restore point.
  • You can use the very useful MMCompView free utility from Nirsoft to disable any codecs on the system. This is very useful to help troubleshoot exactly which component is causing the problem.

There’s another possible solution below of turning off DEP for dllhost, which might not work for everybody.

You may have to add divx+nero executables to the DEP ignore list.

Computer->properties->Advance system settings->settings(performance)->Data Execution Prevention-> then
Select the “Data Execution Protection” tab, and then click “Turn on DEP for all programs and services except those I select”
Click on the Add button, and then browse to C:\Windows\System32\dllhost.exe
Click on Open then Ok.

Unable to install a printer getting error- try this

Unable to install 3 rd party Printer drivers or unable to Add a printer or Not able to start or Stop the Print spooler service  or When you try to print, drug you may receive the following error message Operation cannot be completed. ???

Resolution:  Click Start, cialis right-click My Computer, sale and then click Manage.
Expand Services and Applications, and then click Services.
In the details pane, right-click LexBce Server, and then click Properties.
On the General tab, in the Startup type list, click Disabled.
Under Service status, click Stop, and then click OK.
Right-click the Print Spooler service, and then click Start (if it is stopped).
Exit Computer Management.

There may be cases in which the Print Spooler service does not start after you turn off the LexBce Server service and remove the Lexmark printer drivers. This issue may occur if the Print Spooler service depends on the LexBce Server service. To remove the dependency, and to make the Print Spooler service depend only on the remote procedure call (RPC) service,
follow these steps:

    1. Delete the LexBce Server service. To do this, delete the following registry key:
    HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesLexBces 
    2. Make sure that the Print Spooler service is only dependent on the RPC service. To do this, follow these steps: a.  Locate and then click the following registry key:
    HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesSpooler
    3. In the details pane, if the DependOnService value shows values of RPCSS and LexBce, right-click DependOnService, and then click Modify
    4. In the Value data box, delete LexBce, and then click OK;
    5.  Exit Registry Editor.

Check you were able to use the printer or not if still facing the trouble …. Dont worry
Continue reading

Unable to get the System Information in Windows vista

Resolution:

Step 1: Tried to stop the WMI Servise.

Step 2: Rename the repository folder is located in the :\Windows\system32\wbem directory

Step3:Strat the service  “net start winmgmt”

Step 4: Run the following commands. from the admin/elevated command prompt.

-cd /d %windir%\system32\wbem

-for %i in (*.dll) do RegSvr32 -s %i

-for %i in (*.exe) do %i /RegServer

 

Step5: Restart the computer.

Step6: IF still not able to get the information  then

start the iphelper and security center service. Both these services are dependency of WMI.

 

This works well and good.

Last step would be

  Continue reading